Apps down

Minor incident Crypto Onramp (buy) BTC ETH/ERC-20 SOL Crypto Offramp (sell) BTC ETH/ERC-20 SOL Crypto Transfer BTC ETH/ERC-20 SOL Crypto Swap SEPA Transfer Card Top-up Card Transaction Onboarding Vaults Support Chat
2025-12-12 09:48 GMT · 35 minutes

Updates

Resolved

Access to services is back to normal.

December 12, 2025 · 10:23 GMT
De-escalate

Access to services is recovering

December 12, 2025 · 10:18 GMT
Issue

Access to the platform is degraded, we are currently investigating the causes and will provide as update ASAP.

December 12, 2025 · 09:48 GMT

← Back