Services down

Major incident Crypto Onramp (buy) BTC ETH/ERC-20 SOL Crypto Offramp (sell) BTC ETH/ERC-20 SOL Crypto Transfer BTC ETH/ERC-20 SOL Crypto Swap SEPA Transfer Card Top-up Card Transaction Onboarding Vaults Support Chat
2026-02-04 20:42 GMT · 27 minutes

Updates

Resolved

Issue is resolved.

February 4, 2026 · 21:09 GMT
Monitoring

The problem was identified and a fix is being rolled out to all service. Full access to the platform should be available soon.

We are monitoring the release of the fix to make sure it’s stable.

February 4, 2026 · 20:54 GMT
Investigating

We are investigating the root cause of services being down. We will provide an update as soon as possible

February 4, 2026 · 20:42 GMT

← Back