Investigating failures in crypto activity

Major incident Crypto Onramp (buy) BTC ETH/ERC-20 SOL Crypto Offramp (sell) BTC ETH/ERC-20 SOL Crypto Transfer BTC ETH/ERC-20 SOL Crypto Swap Vaults
2026-04-28 08:56 BST · 4 hours, 37 minutes

Updates

Resolved

This issue has been resolved and services are operating normally.

April 28, 2026 · 13:33 BST
Monitoring

We’ve implemented a fix and are monitoring the recovery.

April 28, 2026 · 11:14 BST
Issue

We’re investigating reports of failures on crypto features affecting all users.

Our team is investigating and working to restore normal service.

April 28, 2026 · 08:56 BST

← Back