Degraded performance on Crypto transfers

Minor incident Crypto Transfer BTC ETH/ERC-20 SOL
2026-04-28 15:25 BST · 6 hours, 9 minutes

Updates

Resolved

Issue is resolved.

April 28, 2026 · 21:34 BST
Monitoring

A fix has been implemented and the team is monitoring the progress.

April 28, 2026 · 21:27 BST
Issue

We’re investigating reports of delaying updates on funds affecting users on crypto transfers.

April 28, 2026 · 15:25 BST

← Back