Degraded performance on cards transactions

Minor incident Card Transaction
2026-05-08 08:48 BST · 2 hours, 36 minutes

Updates

Resolved

Issue upstream has been resolved and all services are back to normal.

May 8, 2026 · 11:20 BST
Investigating

We are investigation degraded performance on card transactions. First observations seems to indicated it’s related with an external outage.

May 8, 2026 · 08:48 BST

← Back