Crypto service degraded performance

Minor incident Crypto Onramp (buy) BTC ETH/ERC-20 SOL Crypto Offramp (sell) BTC ETH/ERC-20 SOL Crypto Transfer BTC ETH/ERC-20 SOL Crypto Swap
2026-05-13 15:01 BST · 55 minutes

Updates

Resolved

Issue is resolved and services are back to normal.

May 13, 2026 · 15:56 BST
Issue

Crypto transactions may be unsuccessful due to a temporary technical issue.
Our team is already investigating the issue and working to resolve it as quickly as possible.

May 13, 2026 · 15:01 BST

← Back