Degraded performance on SEPA transfers

Major incident SEPA Transfer
2026-05-19 11:23 BST · 18 hours, 35 minutes

Updates

Resolved

Issue is resolved by EBA and services are back to normal.

May 20, 2026 · 07:58 BST
Update

Some SEPA Instant transfers are now being processed and sent. While the issue isn’t fully resolved yet, outgoing transfers may still fail or remain pending longer than usual. EBA continues to work on a full resolution.

May 19, 2026 · 22:43 BST
Update

We are currently experiencing a scheme-wide incident affecting SEPA Instant transfers across banks in Europe.
As a result, outgoing EUR transfers may fail or remain pending longer than usual.

May 19, 2026 · 18:07 BST
Investigating

We are investigation degraded performance on SEPA outbound transfers. First observations seems to indicated it’s related with an external outage.

May 19, 2026 · 11:23 BST

← Back