Investigating: BASE Network Outage – Transactions Delayed

Minor incident Crypto Onramp (buy) ETH/ERC-20 Crypto Offramp (sell) ETH/ERC-20 Crypto Transfer ETH/ERC-20 Crypto Swap
2026-06-25 17:03 BST · 18 hours, 46 minutes

Updates

Resolved

This issue has been resolved and BASE network transactions, including Vaults, are operating normally.

June 25, 2026 · 20:22 BST
Issue

Impact: Some customers may experience delays with BASE network transactions, including Vaults. This is due to a network-wide outage on the BASE blockchain, unrelated to Deblock’s infrastructure.

What we’re doing: We are monitoring the situation closely and will resume normal service as soon as the BASE network recovers.

Follow live updates: You can monitor the situation directly on Base’s official status page: https://status.base.org/

June 25, 2026 · 18:21 BST

← Back