Degraded performance on SEPA transfers and crypto transactions
Major incident
Bitcoin
Ethereum / ERC-20
Solana
Sell (offramp)
Crypto swaps
Bitcoin
Ethereum / ERC-20
Solana
SEPA bank transfers
2026-07-15 18:02 BST
· 2 hours, 30 minutes
Updates
Resolved
July 15, 2026 · 20:32 BST
SEPA transfers and crypto transactions are back to normal. The issue has been resolved and all services are operating as expected.
Issue
July 15, 2026 · 18:02 BST
We are currently investigating degraded performance on SEPA transfers and crypto transactions. We will provide updates as we learn more.
← Back
Deblock Status