Degraded performance on SEPA transfers and crypto transactions
Minor incident
Bitcoin
Ethereum / ERC-20
Solana
Sell (offramp)
Crypto swaps
Bitcoin
Ethereum / ERC-20
Solana
SEPA bank transfers
2026-07-16 12:19 BST
· 23 hours, 28 minutes
Updates
Resolved
July 17, 2026 · 11:47 BST
SEPA transfers and crypto transactions are back to normal. The issue has been resolved and all services are operating as expected.
Issue
July 16, 2026 · 12:19 BST
We are currently experiencing delays on SEPA transfers and crypto transactions. We are investigating and will provide updates as we learn more.
← Back
Deblock Status